Hedge
Search…
Requirements
Postlab supports a wide range of setups and versions of macOS and NLEs.

macOS 10.14 and newer.
We do not support 10.13. As Apple stopped supporting 10.14 in November, 2021, we recommend updating to an OS that does receive Security Updates as Postlab relies heavily on SSL/HTTPS connections.

Drive requirements can be found here:

Postlab uses a range of cloud services, which are all essential:

Final Cut Pro 10.3.4 and newer.

Creative Cloud 2019 (13.1.5) and newer.

As with all things Media Composer, its requirements are more complex:
Copy link
On this page
macOS
Drive
Network
Final Cut Pro
Adobe Premiere Pro
Avid Media Composer